Eptura Visitor - S2 - Not able to print or download badge from the web dashboard

Incident Report for Eptura

Postmortem

We are grateful for your continued support and loyalty. We value your feedback and appreciate your patience as we worked to resolve this incident.

Type of Event

S2 – Not able to print or download badge from the web dashboard

Services/Modules Impacted

Eptura Visitor – Admin Dashboard
Android Kiosk Badge Printing

 

Issue Summary/Background

On May 6, 2026, some customers experienced issues when printing or downloading visitor badges from the Eptura Visitor dashboard. During this time, badge print attempts returned an error message, and downloads did not generate a file. Badge printing from kiosk devices was also impacted.

Our team quickly identified that this issue was affecting multiple customers and immediately began working on a resolution. A fix was developed, tested, and deployed the same day. Affected customers were contacted directly, and full functionality was restored within approximately four hours.

 

Root Cause

A recent system update resulted in unexpected behavior that impacted badge printing and downloading across both the Visitor web dashboard and Android kiosks.

As a result: 

  • Badge print requests failed and returned an error message
  • Badge download requests appeared to complete, but the file was not successfully generated
  • Because a shared badge service supports both platforms, all badge generation workflows were affected

Our engineering team quickly identified the issue and deployed a fix to production on May 6 as part of API version 9.27.1306. Badge printing and downloading functionality has since been fully restored.

 

Remediation

Our teams quickly investigated the issue and implemented temporary measures to reduce customer impact while a permanent fix was being prepared.

A hotfix (API version 9.27.1306) was deployed to production on May 6, restoring badge printing and downloading functionality across both the Visitor web dashboard and Android kiosks.

Following deployment, we completed extensive testing across multiple scenarios and confirmed that badge generation was functioning normally again. Support teams also worked directly with affected customers to verify resolution.

To help prevent similar issues in the future, we have introduced:

  • Enhanced monitoring and alerting for badge generation services
  • Additional automated and end-to-end testing across web and kiosk workflows
  • Improved deployment validation and rollback procedures for shared services
  • Stronger release controls for critical functionality

We also provided ongoing customer communications throughout the incident, including status updates, recovery timelines, and post-incident follow-up.

 

Timeline (UTC)

May 06, 2026 – 10:15 AM — First customer cases received

May 06, 2026 – 10:30 AM — Initial triage and validation started

May 06, 2026 – 11:00 AM — Issue reproduced internally; confirmed not account-specific

May 06, 2026 – 11:10 AM — Incident escalated to Engineering

May 06, 2026 – 11:20 AM — Engineering investigation initiated

May 06, 2026 – 11:50 AM — Root cause identified (API regression in badge service)

May 06, 2026 – 12:10 PM — Fix development started

May 06, 2026 – 12:40 PM — Fix completed; QA validation initiated

May 06, 2026 – 01:11 PM — Hotfix deployed to production (API v9.27.1306)

May 06, 2026 – 01:20 PM — Post-deployment validation and monitoring started

May 06, 2026 – 01:30 PM — Began customer outreach for verification

May 06, 2026 – 05:41 PM — Majority of customers confirmed resolution; incident closed

 

Total Duration of Event

Approximately 4 hours 30 minutes

 

Preventive Actions

To help prevent similar issues in the future, we have implemented several improvements, including:

  • Enhanced testing across badge printing and download workflows on both the web dashboard and Android kiosks
  • Improved monitoring and alerting to quickly identify badge generation issues
  • Stronger pre-release validation and review processes for shared services
  • Safer deployment procedures with faster rollback capabilities if issues are detected

All services are operating normally, and we will continue to monitor the platform closely to ensure consistent performance. We appreciate your partnership and patience while we worked to resolve this issue. Your feedback and collaboration play an important role in helping us strengthen the Eptura Visitor experience, and we remain committed to delivering the reliability and performance your organization expects.

Posted May 15, 2026 - 17:15 UTC

Resolved

The issue affecting badge printing and downloading from the Eptura Visitor web dashboard has been resolved.
A hotfix was successfully deployed, and we have continued monitoring the system to confirm stability. Badge printing and badge downloads are now working as expected.
Thank you for your patience.
Posted May 06, 2026 - 12:09 UTC

Monitoring

A hotfix has been identified, developed, and deployed.
Our engineering team is actively monitoring the system to confirm stability. If you continue to experience issues with badge printing or downloading, please reach out to our support team.
We will provide further update once we have confirmed full resolution.
Thank you for your patience.
Posted May 06, 2026 - 09:56 UTC

Investigating

We are investigating an issue where some customers are unable to print or download badges from the web dashboard. When attempting to print, an error is displayed, and when attempting to download a badge, no file is generated. We understand this may be disrupting day‑to‑day operations for teams that rely on badge access.

This issue affects customers using the Web dashboard to print or download badges.

Our engineering team is actively reviewing the issue to identify the root cause and determine the appropriate fix. We are also assessing whether a temporary workaround is available that can be safely shared with customers.

At this time, no action is required from customers. We will provide another update at 11:30 AM UTC.

Thank you for your patience while we work towards resolution.
Posted May 06, 2026 - 07:24 UTC
This incident affected: Eptura Visitor (Admin Dashboard).