Eptura - Visitor - S2 - System Performance Issues

Incident Report for Eptura

Resolved

Following a period of monitoring, the issue has now been fully resolved.

System performance has stabilized, and all services are operating as expected. No further user impact is anticipated at this time.

Our teams will continue standard monitoring to ensure ongoing stability. If you continue to experience any issues, please contact Support by opening a case, and we will assist you accordingly.

Thank you for your patience and understanding while we worked toward resolution.
Posted Feb 05, 2026 - 09:19 UTC

Update

The planned hotfix deployment has now been fully completed. Both hotfixes have been successfully applied, and post-deployment sanity testing has been completed.

Authentication services are functioning as expected, and users are able to log in successfully. Following the deployment, we observed a temporary increase in response times, which is expected behavior during stabilization. Performance has been steadily improving, and system metrics indicate recovery is in progress.

Our teams continue to closely monitor the platform to ensure performance returns to normal levels and remains stable. At this time, no further user impact is expected.

Thank you for your patience and continued support.
Posted Feb 04, 2026 - 14:00 UTC

Monitoring

The required hotfixes have now been successfully applied, and initial validation and sanity testing have been completed. We’re seeing positive signs, with platform performance and response times continuing to improve.

At this stage, the platform is stable, and we’ve moved into a monitoring phase to ensure performance continues to remain consistent. While most users should see normal behaviour, we’ll continue to keep a close watch to quickly address any anomalies if they arise.

We’ll provide a further update if anything changes, or once we’re confident the issue is fully resolved.

Thank you for your continued patience and understanding.
Posted Feb 04, 2026 - 07:48 UTC

Identified

We are currently awaiting an additional hotfix from Engineering, which will be deployed together with a previously delivered fix. Bundling these updates helps minimize user impact, as applying them individually could result in temporary performance degradation.

In the meantime, we continue to actively monitor the platform. While response times have shown periods of improvement, some users may still encounter intermittent slowness until the remaining fix is applied and overall stability is restored.

We will share the next update as soon as the second hotfix is available and implementation is complete.

Thank you for your continued patience.
Posted Feb 04, 2026 - 01:00 UTC

Update

Our teams continue to actively work on the performance degradation impacting the Visitor system.

We are currently waiting on an additional hotfix from engineering, which will be applied together with a previously received fix. These updates are being bundled to minimize user impact, as applying them individually can temporarily affect system performance.

In the meantime, we are closely monitoring the platform. While response times have shown periods of improvement, users may still experience intermittent slowness until the remaining fix is applied and stability is fully restored.

We will provide the next update as soon as the second hotfix is available and implementation is completed.

Thank you for your continued patience.
Posted Feb 03, 2026 - 18:13 UTC

Investigating

We have received reports of performance issues impacting the Visitor system. Users may experience slow page load times and delays in certain workflows. Our engineering teams are actively investigating the root cause and have already identified an area contributing to the degraded performance.

We have begun applying a fix, and initial observations show improving response times. However, during the implementation of this fix, users may continue to experience intermittent performance issues for approximately the next 30 minutes.

We are closely monitoring system behavior to ensure full and sustained recovery.
Posted Feb 03, 2026 - 13:18 UTC
This incident affected: Eptura Visitor (Access Control, Admin Dashboard, APIs / Webhook, Check in / LogBook, Emergency Lists, Integrations).