S2 - Global Cloudflare Outage - Impact on Eptura Services

Incident Report for Eptura

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 09:31 UTC

Monitoring

Cloudflare has confirmed that their services are now operating normally, and they are no longer observing elevated errors or delays.
Posted Dec 05, 2025 - 09:27 UTC

Investigating

We have identified that the issues currently affecting Eptura products are related to a global Cloudflare incident

https://www.cloudflarestatus.com/

Our teams are actively monitoring the situation, and we will continue to update this incident.
Posted Dec 05, 2025 - 09:22 UTC
This incident affected: Eptura Asset, Eptura Workplace, and Teem.