Our Product team has confirmed that the Eptura Asset Companion app is now visible in the Apple store again. We have moved to the Resolved Phase. A Preliminary RCA will be posted in this incident in 2 business days. Please stay subscribed to the page to receive post automatically.
Posted Oct 29, 2025 - 21:54 UTC
Identified
.
Posted Oct 29, 2025 - 17:31 UTC
Update
We are continuing to investigate the issue preventing the Asset Work Companion (Eptura Asset App) from appearing in the Apple App Store. Our team is working to identify the root cause and restore availability as soon as possible.
We appreciate your patience and understanding as we work through this.
Next update will be posted by 1700 UTC on October 30, 2025, or sooner if more information becomes available.
Posted Oct 29, 2025 - 17:03 UTC
Investigating
We are currently investigating an issue with the Asset Work Companion/Eptura Asset App not being visible in the Apple Store.
Our Product team is currently investigating to determine the cause and to get the app available for download as soon as possible.
We appreciate your patience as we work through this issue.
Next update will be posted at 1700 UTC October 29th 2025.